Skip to content

Cinema 4D tutorial

The Conductor submitter for Cinema 4D allows you to ship renders to Conductor from a dialog within Cinema 4D.

This tutorial should get you going quickly. Please check the Cinema 4D reference page for a detailed description.

If you haven't already done so, Download the Companion App.

Open the Companion app on the Plugins page and install the Cinema 4D plugin.

Register the Plugin

To register the submitter plugin with Cinema 4D:

  • Go to Edit->Preferences->Plugins and browse for cioc4d in the installation directory. By default, this will be:
~/Conductor/cioc4d
~/Conductor/cioc4d
C:\Users\<username>\Conductor\cioc4d

prefs

  • Restart Cinema 4D, you should now see Conductor Render in the Render menu. If not, submit a ticket to Conductor Support.

  • Open a scene to be rendered. We currently support Redshift and the default Cinema 4D renderer.

Relative paths.

If running Windows, your project should be made portable by using relative asset paths and output paths. We provide a simple function to handle this.

  • Open the Render menu and choose Make Portable

If you check the Asset Inspector and Render Settings, you'll see all paths have been localized or made relative to the c4d document.

Set submission parameters

  • To open the submitter dialog, Choose Conductor Render from the Render menu or the Extensions menu.

menu

  • Set a title to show up on the Conductor dashboard when you submit. By default, the title may use any Cinema 4D tokens that are in context. This includes $prj, $camera, and $take, but not $pass
  • Check that a suitable version of Cinema 4D appears in the Cinema 4D Version field, and choose a renderer version.
  • Choose a suitable machine spec from the Instance Type drop-down menu. Redshift requires a graphics card, and you'll get an error if you try to submit a Redshift render on a machine with no GPU.

dialog

Because the submitter has not yet connected with your account at Conductor, the project is - Not Connected -, and the pulldown menu is empty.

  • Press the Connect button at the bottom of the dialog and, if prompted, sign in to Conductor.
  • Choose a project from the Project drop-down menu.
  • In the Frames section, turn on Use Custom Frames and enter 1-10 in the Custom Frames field.
  • Set Chunk Size to 1.
  • Turn on Use Scout Frames and enter auto:3 in the Scout Frames field.

You'll notice the Frame Info section is updated to let you know which frames will be submitted and how many are due to be scouted first.

frames

Submit the job

You are now ready to submit your render using the Submit button at the bottom of the dialog. On submission, several validations will run to catch any issues that could cause the render to fail. You can also check the Preview section for potential problems in the submission payload.

preview

If everything looks good, press the Submit button, and then head over to the Conductor dashboard to monitor your job.

Be sure to visit the Cinema 4D reference page for more info.

Back to top